WordPress security changelog
HIGH CVE-2026-65640 Awaiting Analysis

WordPress PostScript uploads permit Author-level remote code execution

WordPress before 7.0.4 permits remote code execution when an Author or another user with the upload_files capability uploads a malicious PostScript file on a server that processes images with both Imagick and Ghostscript. The malicious file reaches that image-processing stack and can execute code on the server. WordPress 7.0.4 fixes the issue, and the fix was backported to maintained branches through 4.7.

CVE / CNA score 8.8 CVSS 3.0 · support@hackerone.com
NVD score Pending NVD has not published its own CVSS assessment.
Component
WordPress
Plugin slug
Core
Affected
< 7.0.4
Safe version
7.0.4
Published
Aug 17, 2026
Weakness
CWE-434 — Unrestricted Upload of File with Dangerous Type

This CVE was published Aug 17, 2026 and is one of 51 known issues for WordPress core.

Update, patch or deactivate.

Update to WordPress 7.0.4 or the latest fixed maintenance release for the site's supported branch. Restrict upload_files to trusted users and review Author-level accounts, uploads and server activity when Imagick and Ghostscript are present.

A safe version is available, so updating to that version or later is the preferred remediation. If an immediate update is not practical, consider a targeted application patch or temporarily restricting the affected functionality.

Deactivate only when warranted by your risk profile, or when advised by your hosting provider in the limited circumstances where the vulnerability cannot otherwise be mitigated. If you’re unsure which action is appropriate, contact Fused or your hosting provider for guidance.

Technical description

WordPress is vulnerable to a remote code execution vulnerability via malicious Postscript file upload by an Author level user or higher. Prerequisites: * Imagick and Ghostscript in use on the server * A malicious user with the `upload_files` capability This issue affects all versions of WordPress. Version 7.0.4 has been released, containing a fix for the vulnerability, and as a courtesy to users on older branches the fix has been backported to all branches back to 4.7.

CVE / CNA vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Primary and upstream sources