WordPress security changelog
MEDIUM CVE-2026-97070 Deferred

Cozy Blocks: Authorization bypass through a user-controlled key

No attacker login is required by the supplied CVSS vector. A caller-controlled key selects a resource without the intended object-level permission check. The vector reports limited disclosure of protected information without victim interaction. The key, resource type and exact bypassed boundary are undisclosed; the record does not establish a login bypass or administrator takeover. The authoritative export does not identify the vulnerable endpoint, action, parameter or function, so the exact input-to-operation path cannot be established from this record. Affected versions: <= 2.2.23. The authoritative export identifies 2.2.24 as fixed for this CVE.

CVE / CNA score 6.9 CVSS 4.0 · audit@patchstack.com
NVD score Pending NVD has not published its own CVSS assessment.
Component
Cozy Blocks
Plugin slug
cozy-addons
Affected
<= 2.2.23
Safe version
2.2.24
Published
Oct 05, 2026
Weakness
CWE-639 — Authorization Bypass Through User-Controlled Key

This CVE was published Oct 05, 2026 and is one of 14 known issues for this plugin.

Update, patch or deactivate.

Update Cozy Blocks to 2.2.24 or a later supported release. An application-level fix should address the following: Check ownership and the intended permission for the exact selected object on every request. A request-supplied key or identifier must not act as authorization.

A safe version is available, so updating to that version or later is the preferred remediation. If an immediate update is not practical, consider a targeted application patch or temporarily restricting the affected functionality.

Deactivate only when warranted by your risk profile, or when advised by your hosting provider in the limited circumstances where the vulnerability cannot otherwise be mitigated. If you’re unsure which action is appropriate, contact Fused or your hosting provider for guidance.

Technical description

Authorization Bypass Through User-Controlled Key vulnerability in CozyThemes Cozy Blocks cozy-addons allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Cozy Blocks: from n/a through 2.2.23.

CVE / CNA vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X

Primary and upstream sources