Enable Media Replace
Enable Media Replace replaces media files in the WordPress library while preserving their existing attachment references and URLs.
Enable Media Replace (enable-media-replace) is a WordPress plugin with 11 published CVE records in this archive. The latest tracked vulnerability was published Oct 30, 2026; the highest published CVSS base score is 8.8.
enable-media-replaceCVE-2026-114422: Enable Media Replace: PHP object injection
The Enable Media Replace WordPress plugin before 4.2.3 does not restrict the classes allowed when deserializing stored metadata during its media replace-and-update-links routine, allowing unauthenticated users to inject a PHP object that is instantiated when a user with upload access performs a routine media replacement, resulting in PHP Object Injection and local file inclusion of existing PHP/HTML files, which can be escalated to remote code execution where an attacker-influenced PHP or HTML file is present on the server. This is a regression of CVE-2023-4643, which was fixed in 4.1.3 and reintroduced in 4.1.4. The structured affected range is 4.1.4 to < 4.2.3.
| Safe version |
|
||
|---|---|---|---|
| Oct 30, 2026 |
CVE-2026-114422
Enable Media Replace: PHP object injection
The Enable Media Replace WordPress plugin before 4.2.3 does not restrict the classes allowed when deserializing stored metadata during its media replace-and-update-links routine, allowing unauthenticated users to inject a PHP object that is instantiated when a user with upload access performs a routine media replacement, resulting in PHP Object Injection and local file inclusion of existing PHP/HTML files, which can be escalated to remote code execution where an attacker-influenced PHP or HTML file is present on the server. This is a regression of CVE-2023-4643, which was fixed in 4.1.3 and reintroduced in 4.1.4. The structured affected range is 4.1.4 to < 4.2.3.
|
4.2.3 |
CVEPending
|
| Oct 28, 2026 |
CVE-2026-85655
Enable Media Replace: Unauthorized post modification
The Enable Media Replace plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 4.2.2. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for authenticated attackers, with author-level access and above, to modify the post_content of any published post referencing the replaced media — including Administrator-owned posts — making changes immediately visible to unauthenticated visitors. The doReplaceQuery() method performs a database-wide search-and-replace across all posts containing the old media URL without any per-post capability check, meaning a single Author-triggered request can silently overwrite a large number of posts that WordPress's standard admin UI and REST API would otherwise forbid that user from editing. The structured affected range is <= 4.2.2.
|
4.2.3 |
CVE4.3
|
| Jul 01, 2026 |
CVE-2026-57722
Enable Media Replace: Cross-site scripting
Enable Media Replace is affected by cross-site scripting. Exposure depends on how the affected operation is made reachable by the site. Injected script can execute in the affected site's origin when the vulnerable output is viewed. The published affected range is n/a through 4.2.1.
|
4.2.2 |
CVE5.9
|
| Jun 09, 2026 |
CVE-2026-5714
Enable Media Replace stores scripts through location_dir
An authenticated Author or higher can supply attacker-controlled content through the location_dir parameter in Enable Media Replace through 4.1.8. Insufficient input sanitization and output escaping allow that content to be stored and later execute as script when a user views an affected page. The endpoint, storage location and exact rendering function are unspecified. Confirmed fixed release: 4.1.9.
|
4.1.9 |
CVE6.4
|
| Mar 04, 2026 |
CVE-2026-2732
Enable Media Replace: A security weakness
Enable Media Replace is affected by a security weakness. Exploitation requires an authenticated author account. The resulting impact depends on how the affected component exposes the vulnerable operation.
|
See mitigation notes |
CVE5.4
|
| Oct 11, 2025 |
CVE-2025-9496
Enable Media Replace: Cross-site scripting
Enable Media Replace is affected by cross-site scripting. Exploitation requires an authenticated contributor account. Injected script can execute in the affected site's origin when the vulnerable output is viewed.
|
See mitigation notes |
CVE6.4
|
| Apr 01, 2025 |
CVE-2025-31081
Enable Media Replace: Cross-site scripting
Enable Media Replace is affected by cross-site scripting. Exposure depends on how the affected operation is made reachable by the site. Injected script can execute in the affected site's origin when the vulnerable output is viewed.
|
See mitigation notes |
CVE7.1
|
| Jan 11, 2024 |
CVE-2023-6737
Enable Media Replace: Cross-site scripting
Enable Media Replace is affected by cross-site scripting. The vulnerable path is reachable without authentication. Injected script can execute in the affected site's origin when the vulnerable output is viewed.
|
See mitigation notes |
CVE4.7
|
| Oct 16, 2023 |
CVE-2023-4643
Enable Media Replace: Code execution
Enable Media Replace is affected by code execution. Exposure depends on how the affected operation is made reachable by the site. Successful exploitation can run attacker-controlled code in the WordPress hosting account.
|
See mitigation notes |
CVE8.8
|
| Feb 13, 2023 |
CVE-2023-0255
Enable Media Replace: A security weakness
Enable Media Replace is affected by a security weakness. Exposure depends on how the affected operation is made reachable by the site. The resulting impact depends on how the affected component exposes the vulnerable operation.
|
See mitigation notes |
CVE8.8
|
| Oct 10, 2022 |
CVE-2022-2554
Enable Media Replace: Filesystem traversal
Enable Media Replace is affected by filesystem traversal. Exposure depends on how the affected operation is made reachable by the site. A crafted path can escape the intended directory and reach files or directories elsewhere on the server.
|
See mitigation notes |
CVEPending
|