Flexible Quantity – Measurement Price Calculator for WooCommerce: Unauthenticated quantity manipulation
An unauthenticated attacker, according to the CNA vector, can submit a quantity that is not properly validated before it is used in an operation. The export reports input-data manipulation and limited integrity impact but does not disclose the endpoint, quantity field, permitted range or resulting business change. It does not establish a particular underpayment or negative-quantity exploit. Affected versions: <= 2.3.22. The authoritative export identifies 2.3.23 as fixed for this CVE.
- Component
- Flexible Quantity – Measurement Price Calculator for WooCommerce
- Affected
- <= 2.3.22
- Safe version
2.3.23- Published
- Oct 12, 2026
This CVE was published Oct 12, 2026 and is one of 4 known issues for this plugin.
Update, patch or deactivate.
Update to 2.3.23 or a later supported release. Application-level remediation: Validate quantity type, range and business constraints server-side, and recompute dependent values from trusted data before committing the operation.
A safe version is available, so updating to that version or later is the preferred remediation. If an immediate update is not practical, consider a targeted application patch or temporarily restricting the affected functionality.
Deactivate only when warranted by your risk profile, or when advised by your hosting provider in the limited circumstances where the vulnerability cannot otherwise be mitigated. If you’re unsure which action is appropriate, contact Fused or your hosting provider for guidance.
Technical description
Improper Validation of Specified Quantity in Input vulnerability in WP Desk Flexible Quantity – Measurement Price Calculator for WooCommerce flexible-quantity-measurement-price-calculator-for-woocommerce allows Input Data Manipulation.This issue affects Flexible Quantity – Measurement Price Calculator for WooCommerce: from n/a through 2.3.22.
CVE / CNA vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N