GeoDirectory permits unauthenticated cross-site scripting
GeoDirectory <= 2.8.173 allows an unauthenticated attacker to supply script-capable input that reaches browser output without adequate neutralization. The CNA vector requires victim interaction and assigns changed scope with low confidentiality, integrity and availability impact. Script executes in the site's origin when a victim interacts with the affected output.
- Component
- GeoDirectory
- Plugin slug
geodirectory- Affected
- n/a through 2.8.173
- Safe version
2.8.174- Published
- Aug 20, 2026
This CVE was published Aug 20, 2026 and is one of 42 known issues for this plugin.
Update, patch or deactivate.
Update GeoDirectory to 2.8.174 or later. Review activity by the stated attacker class and investigate unexpected data access, state changes, files or sessions relevant to this vulnerability class.
A safe version is available, so updating to that version or later is the preferred remediation. If an immediate update is not practical, consider a targeted application patch or temporarily restricting the affected functionality.
Deactivate only when warranted by your risk profile, or when advised by your hosting provider in the limited circumstances where the vulnerability cannot otherwise be mitigated. If you’re unsure which action is appropriate, contact Fused or your hosting provider for guidance.
Technical description
Unauthenticated Cross Site Scripting (XSS) in GeoDirectory <= 2.8.173 versions.
CVE / CNA vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L