WordPress security changelog
CRITICAL CVE-2026-84813 Deferred

GeoDirectory permits unauthenticated SQL injection

GeoDirectory through 2.8.174 allows unauthenticated attacker-controlled input to reach an unsafe database query. Exploitation can extract sensitive database contents and disrupt affected queries.

CVE / CNA score 9.3 CVSS 3.1 · audit@patchstack.com
NVD score Pending NVD has not published its own CVSS assessment.
Component
GeoDirectory
Plugin slug
geodirectory
Affected
n/a through 2.8.174
Safe version
2.8.175
Published
Sep 03, 2026
Weakness
CWE-89 — Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')

This CVE was published Sep 03, 2026 and is one of 42 known issues for this plugin.

Update, patch or deactivate.

Update to 2.8.175 or later, review request and database logs, and rotate credentials if database contents may have been exposed.

A safe version is available, so updating to that version or later is the preferred remediation. If an immediate update is not practical, consider a targeted application patch or temporarily restricting the affected functionality.

Deactivate only when warranted by your risk profile, or when advised by your hosting provider in the limited circumstances where the vulnerability cannot otherwise be mitigated. If you’re unsure which action is appropriate, contact Fused or your hosting provider for guidance.

Technical description

Unauthenticated SQL Injection in GeoDirectory <= 2.8.174 versions.

CVE / CNA vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:L

Primary and upstream sources