WordPress security changelog
MEDIUM CVE-2026-96766 Deferred

GeoDirectory – WP Business Directory Plugin and Classified Listings Directory: Cross-site scripting

GeoDirectory (affected: <= 2.8.183). A Subscriber who owns a listing can submit script markup in business_hours. The AJAX save handler checks only authorship and a nonce, without an additional capability restriction, and insufficient validation/escaping lets the stored value execute for later viewers. The handler's exact action name is unspecified.

CVE / CNA score 6.4 CVSS 3.1 · security@wordfence.com
NVD score Pending NVD has not published its own CVSS assessment.
Component
GeoDirectory – WP Business Directory Plugin and Classified Listings Directory
Plugin slug
geodirectory
Affected
<= 2.8.183
Safe version
2.8.184
Published
Sep 25, 2026
Weakness
CWE-79 — Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

This CVE was published Sep 25, 2026 and is one of 42 known issues for this plugin.

Update, patch or deactivate.

Update to 2.8.184 or a later supported release. The official changelog confirms remediation for this issue. Validate the business-hours structure server-side, enforce editing capabilities and escape output in each display context, including existing listings.

A safe version is available, so updating to that version or later is the preferred remediation. If an immediate update is not practical, consider a targeted application patch or temporarily restricting the affected functionality.

Deactivate only when warranted by your risk profile, or when advised by your hosting provider in the limited circumstances where the vulnerability cannot otherwise be mitigated. If you’re unsure which action is appropriate, contact Fused or your hosting provider for guidance.

Technical description

The GeoDirectory – WP Business Directory Plugin and Classified Listings Directory plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'business_hours' parameter in all versions up to, and including, 2.8.183 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This is possible because the AJAX save handler validates only post authorship and a nonce with no additional capability check, allowing any subscriber-level user who owns a listing to exploit this vulnerability.

CVE / CNA vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

Primary and upstream sources