GiveWP: Privilege escalation
No attacker login is required. An attacker can cross a permission boundary and gain privileges beyond those intended for the caller. The role-changing operation, target privilege and endpoint are undisclosed. The supplied vector reports high confidentiality impact, high integrity impact, high availability impact. The vector rates attack complexity as high; the extra prerequisite is undisclosed. The vector requires no victim interaction. Affected versions: <= 4.17.0. The authoritative export identifies 4.18.0 as fixed for this CVE.
- Component
- GiveWP
- Plugin slug
give- Affected
- n/a through 4.17.0
- Safe version
4.18.0- Published
- Oct 06, 2026
This CVE was published Oct 06, 2026 and is one of 69 known issues for this plugin.
Update, patch or deactivate.
Update GiveWP to 4.18.0 or a later supported release. Application-level remediation: Authorize each privilege-changing operation against the acting user, disallow client-selected privileged roles, and enforce capability checks before any user or role update.
A safe version is available, so updating to that version or later is the preferred remediation. If an immediate update is not practical, consider a targeted application patch or temporarily restricting the affected functionality.
Deactivate only when warranted by your risk profile, or when advised by your hosting provider in the limited circumstances where the vulnerability cannot otherwise be mitigated. If you’re unsure which action is appropriate, contact Fused or your hosting provider for guidance.
Technical description
Unauthenticated Privilege Escalation in GiveWP <= 4.17.0 versions.
CVE / CNA vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H