Import and export users and customers: Sensitive information exposure
Import and export users and customers is affected by sensitive information exposure. Exploitation requires an authenticated subscriber account. Successful exploitation can disclose data that should not be available to the caller. The published affected range is <= 2.4.0.
- Component
- Import and export users and customers
- Plugin slug
import-users-from-csv-with-meta- Affected
- <= 2.4.0
- Safe version
2.4.1- Published
- Jul 10, 2026
- Weakness
- CWE-862 — Missing Authorization
This CVE was published Jul 10, 2026 and is one of 21 known issues for this plugin.
Update, patch or deactivate.
The official author release notes confirm remediation by 2.4.1; this does not establish that every intervening release was affected. Update the affected edition to 2.4.1 or a later maintained release on its supported branch. Official author release notes: https://wordpress.org/plugins/import-users-from-csv-with-meta/.
A safe version is available, so updating to that version or later is the preferred remediation. If an immediate update is not practical, consider a targeted application patch or temporarily restricting the affected functionality.
Deactivate only when warranted by your risk profile, or when advised by your hosting provider in the limited circumstances where the vulnerability cannot otherwise be mitigated. If you’re unsure which action is appropriate, contact Fused or your hosting provider for guidance.
Technical description
The Import and export users and customers plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 2.4.0 via the email_template_selected. This makes it possible for authenticated attackers, with subscriber-level access and above, to extract the post_title and raw post_content of arbitrary posts regardless of status (draft, private, future, trash, password-protected) or post type (including non-public CPTs such as WooCommerce orders and internal CRM records) by enumerating post IDs. The required codection-security nonce is exposed as inline JavaScript on any wp-admin page when ?post_type=acui_email_template is appended to the URL, which is reachable by any authenticated user including Subscribers.
CVE / CNA vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Primary and upstream sources
- NVD record for CVE-2026-15026
- WordPress upstream reference plugins.trac.wordpress.org
- WordPress upstream reference plugins.trac.wordpress.org
- WordPress upstream reference plugins.trac.wordpress.org
- WordPress upstream reference plugins.trac.wordpress.org
- WordPress upstream reference plugins.trac.wordpress.org
- WordPress upstream reference plugins.trac.wordpress.org
- WordPress upstream reference plugins.trac.wordpress.org
- Wordfence advisory wordfence.com