WordPress security changelog
MEDIUM CVE-2026-105879 Deferred

JetElements For Elementor: Stored cross-site scripting

The supplied CVSS vector requires a low-privilege authenticated account; the minimum WordPress role is undisclosed. Attacker-controlled content is saved and later rendered without sufficient neutralization, allowing script execution under the site's origin when a victim encounters the affected output. The endpoint, field, rendering function and victim role are undisclosed. The supplied vector reports limited confidentiality impact, limited integrity impact, limited availability impact. Victim interaction is required by the vector. Affected versions: <= 2.9.2.2. The authoritative export identifies 2.9.2.3 as fixed for this CVE.

CVE / CNA score 6.5 CVSS 3.1 · audit@patchstack.com
NVD score Pending NVD has not published its own CVSS assessment.
Component
JetElements For Elementor
Plugin slug
jet-elements
Affected
<= 2.9.2.2
Safe version
2.9.2.3
Published
Oct 06, 2026
Weakness
CWE-79 — Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

This CVE was published Oct 06, 2026 and is one of 20 known issues for this plugin.

Update, patch or deactivate.

Update JetElements For Elementor to 2.9.2.3 or a later supported release. Application-level remediation: Validate accepted input and apply context-appropriate escaping at every output sink. Restrict who may submit content and remove any persisted malicious values.

A safe version is available, so updating to that version or later is the preferred remediation. If an immediate update is not practical, consider a targeted application patch or temporarily restricting the affected functionality.

Deactivate only when warranted by your risk profile, or when advised by your hosting provider in the limited circumstances where the vulnerability cannot otherwise be mitigated. If you’re unsure which action is appropriate, contact Fused or your hosting provider for guidance.

Technical description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Crocoblock JetElements For Elementor jet-elements allows Stored XSS.This issue affects JetElements For Elementor: from n/a through 2.9.2.2.

CVE / CNA vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L

Primary and upstream sources