JetElements For Elementor: Stored cross-site scripting
A low-privilege authenticated attacker can store script-bearing input that is later rendered without sufficient contextual escaping. A victim must view or otherwise interact with the affected content for script to execute under the site origin. The export does not identify the exact attacker role, stored field, endpoint, rendering function or victim role; an administrator victim is not established by this record. Affected versions: <= 2.9.2.4. The CNA identifies 2.9.2.5 as the fixed release.
- Component
- JetElements For Elementor
- Plugin slug
jet-elements- Affected
- <= 2.9.2.4
- Safe version
2.9.2.5- Published
- Oct 19, 2026
This CVE was published Oct 19, 2026 and is one of 20 known issues for this plugin.
Update, patch or deactivate.
Update JetElements For Elementor to 2.9.2.5 or a later supported release. The completed CNA record identifies this fixed boundary. Validate and sanitize saved input and apply context-appropriate escaping at every rendering location; restrict editing to authorized users without treating authentication as sufficient input validation.
A safe version is available, so updating to that version or later is the preferred remediation. If an immediate update is not practical, consider a targeted application patch or temporarily restricting the affected functionality.
Deactivate only when warranted by your risk profile, or when advised by your hosting provider in the limited circumstances where the vulnerability cannot otherwise be mitigated. If you’re unsure which action is appropriate, contact Fused or your hosting provider for guidance.
Technical description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Crocoblock JetElements For Elementor jet-elements allows Stored XSS.This issue affects JetElements For Elementor: from n/a through 2.9.2.4.
CVE / CNA vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L