WordPress security changelog
MEDIUM CVE-2026-114707 Deferred

JetElements For Elementor: Stored cross-site scripting

JetElements For Elementor <= 2.9.2.5 permits stored cross-site scripting: attacker-controlled content is persisted and later rendered without sufficient neutralization, allowing script to execute in a viewer’s browser under the affected site’s origin. The supplied CVSS vector requires a low-privilege authenticated attacker and victim interaction, but the export does not identify the minimum WordPress role, editable field, endpoint or rendering function. The resulting access is bounded by the viewing user’s browser context; an administrator victim or complete site takeover is not established.

CVE / CNA score 6.5 CVSS 3.1 · audit@patchstack.com
NVD score Pending NVD has not published its own CVSS assessment.
Component
JetElements For Elementor
Plugin slug
jet-elements
Affected
<= 2.9.2.5
Safe version
2.9.2.6
Published
Oct 26, 2026
Weakness
CWE-79 — Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

This CVE was published Oct 26, 2026 and is one of 20 known issues for this plugin.

Update, patch or deactivate.

Update JetElements For Elementor to 2.9.2.6 or later. The application fix must neutralize stored input and escape it for its final HTML, attribute or script context. Inspect content editable by the affected low-privilege users and remove injected markup; do not rely on output handling that turns encoded content back into executable markup.

A safe version is available, so updating to that version or later is the preferred remediation. If an immediate update is not practical, consider a targeted application patch or temporarily restricting the affected functionality.

Deactivate only when warranted by your risk profile, or when advised by your hosting provider in the limited circumstances where the vulnerability cannot otherwise be mitigated. If you’re unsure which action is appropriate, contact Fused or your hosting provider for guidance.

Technical description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Crocoblock JetElements For Elementor jet-elements allows Stored XSS.This issue affects JetElements For Elementor: from n/a through 2.9.2.5.

CVE / CNA vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L

Primary and upstream sources