JetElements For Elementor allows contributor-level cross-site scripting
JetElements For Elementor through 2.9.2.1 has a cross-site-scripting vulnerability requiring Contributor access. The disclosed XSS class allows attacker-influenced data to become executable browser content, and the CNA vector requires victim interaction. The export does not distinguish stored from reflected XSS or name the route, field, rendering function, output context or interaction needed; it does not establish which users can be targeted. The affected-version data marks 2.9.2.2 unaffected.
- Component
- JetElements For Elementor
- Plugin slug
jet-elements- Affected
- n/a through 2.9.2.1
- Safe version
2.9.2.2- Published
- Sep 17, 2026
This CVE was published Sep 17, 2026 and is one of 20 known issues for this plugin.
Update, patch or deactivate.
Update JetElements For Elementor to 2.9.2.2 or later. Validate input according to its expected type and escape it at the final HTML, attribute, URL or JavaScript output context. Restrict rich markup to an explicit safe allowlist; do not assume that input sanitization alone prevents XSS.
A safe version is available, so updating to that version or later is the preferred remediation. If an immediate update is not practical, consider a targeted application patch or temporarily restricting the affected functionality.
Deactivate only when warranted by your risk profile, or when advised by your hosting provider in the limited circumstances where the vulnerability cannot otherwise be mitigated. If you’re unsure which action is appropriate, contact Fused or your hosting provider for guidance.
Technical description
Contributor Cross Site Scripting (XSS) in JetElements For Elementor <= 2.9.2.1 versions.
CVE / CNA vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L