WordPress security changelog
HIGH CVE-2026-103354 Deferred

Kadence Blocks: Unauthenticated stored cross-site scripting

Kadence Blocks through 3.7.11.1 permits stored cross-site scripting. The authoritative CVSS vector requires no attacker privileges and does require victim interaction. Attacker-controlled data can persist and later execute as script when a victim encounters the affected output. The authoritative export does not identify the submission endpoint, stored field, block, rendering function, victim role or configuration prerequisites; the exact unauthenticated storage path is not disclosed. The export identifies 3.7.12 as the fixed release.

CVE / CNA score 7.1 CVSS 3.1 · audit@patchstack.com
NVD score Pending NVD has not published its own CVSS assessment.
Component
Gutenberg Blocks by Kadence Blocks
Plugin slug
kadence-blocks
Affected
<= 3.7.11.1
Safe version
3.7.12
Published
Oct 04, 2026
Weakness
CWE-79 — Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

This CVE was published Oct 04, 2026 and is one of 25 known issues for this plugin.

Update, patch or deactivate.

Update Kadence Blocks to 3.7.12 or a later supported release. An application-level fix should validate and sanitize persisted input, then escape it for every rendering context rather than trusting stored data. Review and remove malicious content already stored through the affected feature. The export does not identify the field or rendering function, so a more specific source patch is not established.

A safe version is available, so updating to that version or later is the preferred remediation. If an immediate update is not practical, consider a targeted application patch or temporarily restricting the affected functionality.

Deactivate only when warranted by your risk profile, or when advised by your hosting provider in the limited circumstances where the vulnerability cannot otherwise be mitigated. If you’re unsure which action is appropriate, contact Fused or your hosting provider for guidance.

Technical description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Liquid Web / StellarWP Gutenberg Blocks by Kadence Blocks kadence-blocks allows Stored XSS.This issue affects Gutenberg Blocks by Kadence Blocks: from n/a through 3.7.11.1.

CVE / CNA vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L

Primary and upstream sources