Kadence Blocks — Page Builder Toolkit for Gutenberg Editor: A security weakness
Kadence Blocks — Page Builder Toolkit for Gutenberg Editor is affected by a security weakness. Exploitation requires an authenticated contributor account. The resulting impact depends on how the affected component exposes the vulnerable operation. The published affected range is <= 3.5.32.
- Component
- Kadence Blocks — Page Builder Toolkit for Gutenberg Editor
- Plugin slug
kadence-blocks- Affected
- <= 3.5.32
- Safe version
3.7.8- Published
- Jul 10, 2026
This CVE was published Jul 10, 2026 and is one of 25 known issues for this plugin.
Update, patch or deactivate.
The official author release notes confirm remediation by 3.6.0; this does not establish that every intervening release was affected. Update the affected edition to 3.7.8 or a later maintained release on its supported branch. The recommended 3.7.8 release incorporates later related fixes or hardening. The earlier author-attributed remediation remains 3.6.0; recommending a later release does not by itself prove the earlier fix failed. Official author release notes: https://wordpress.org/plugins/kadence-blocks/.
A safe version is available, so updating to that version or later is the preferred remediation. If an immediate update is not practical, consider a targeted application patch or temporarily restricting the affected functionality.
Deactivate only when warranted by your risk profile, or when advised by your hosting provider in the limited circumstances where the vulnerability cannot otherwise be mitigated. If you’re unsure which action is appropriate, contact Fused or your hosting provider for guidance.
Technical description
The Gutenberg Blocks with AI by Kadence WP – Page Builder Features plugin for WordPress is vulnerable to unauthorized post publication in all versions up to, and including, 3.5.32 due to a misconfigured capability check on the 'get_items_permission_check' function permission callback of the 'process_pattern' REST API endpoint. This makes it possible for authenticated attackers, with Contributor-level access and above, to create and immediately publish posts of any type (including pages), bypassing the standard WordPress review workflow where contributors must submit posts for administrator approval.
CVE / CNA vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N