Kadence Blocks — Page Builder Toolkit for Gutenberg Editor: A security weakness
Kadence Blocks — Page Builder Toolkit for Gutenberg Editor is affected by a security weakness. Exploitation requires an authenticated contributor account. The resulting impact depends on how the affected component exposes the vulnerable operation. The published affected range is <= 3.6.3.
- Component
- Kadence Blocks — Page Builder Toolkit for Gutenberg Editor
- Plugin slug
kadence-blocks- Affected
- <= 3.6.3
- Safe version
3.7.9.1 (confirmed by; first fixed release not established)- Published
- Apr 04, 2026
- Weakness
- CWE-862 — Missing Authorization
This CVE was published Apr 04, 2026 and is one of 25 known issues for this plugin.
Update, patch or deactivate.
The official author release notes confirm remediation by 3.7.8; this does not establish that every intervening release was affected. The first fixed release is not established. Update the affected edition to 3.7.9.1 or a later maintained release on its supported branch. The recommended 3.7.9.1 release incorporates later related fixes or hardening. The earlier author-attributed remediation remains 3.7.8; recommending a later release does not by itself prove the earlier fix failed. Official author release notes: https://wordpress.org/plugins/kadence-blocks/.
A safe version is available, so updating to that version or later is the preferred remediation. If an immediate update is not practical, consider a targeted application patch or temporarily restricting the affected functionality.
Deactivate only when warranted by your risk profile, or when advised by your hosting provider in the limited circumstances where the vulnerability cannot otherwise be mitigated. If you’re unsure which action is appropriate, contact Fused or your hosting provider for guidance.
Technical description
The Kadence Blocks — Page Builder Toolkit for Gutenberg Editor plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 3.6.3. This is due to the plugin not properly verifying that a user has the `upload_files` capability in the `process_pattern` REST API endpoint. This makes it possible for authenticated attackers, with contributor level access and above, to upload images to the WordPress Media Library by supplying remote image URLs that the server downloads and creates as media attachments.
CVE / CNA vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N