Kadence Blocks exposes sensitive data to Contributors
A logged-in Contributor can retrieve sensitive data through Kadence Blocks 3.7.8 and earlier.
- Component
- Gutenberg Blocks by Kadence Blocks
- Plugin slug
kadence-blocks- Affected
- n/a through 3.7.8
- Safe version
3.7.8.1- Published
- Aug 06, 2026
This CVE was published Aug 06, 2026 and is one of 25 known issues for this plugin.
Update, patch or deactivate.
Update Kadence Blocks to 3.7.8.1 or later and restrict Contributor access until updated.
A safe version is available, so updating to that version or later is the preferred remediation. If an immediate update is not practical, consider a targeted application patch or temporarily restricting the affected functionality.
Deactivate only when warranted by your risk profile, or when advised by your hosting provider in the limited circumstances where the vulnerability cannot otherwise be mitigated. If you’re unsure which action is appropriate, contact Fused or your hosting provider for guidance.
Technical description
Contributor Sensitive Data Exposure in Gutenberg Blocks by Kadence Blocks <= 3.7.8 versions.
CVE / CNA vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N