Kirki: Quantity validation failure exposes restricted functionality
Kirki through 6.3.1 has an input-quantity validation failure that permits access to functionality not properly constrained by access controls. The authoritative CVSS vector requires neither an attacker account nor victim interaction and reports high confidentiality and low integrity impact. The export does not identify the operation, endpoint, parameter, invalid quantity or exposed data; a specific exploitation path is not disclosed. The authoritative export identifies the fixed release as 6.3.2.
- Component
- Kirki
- Plugin slug
kirki- Affected
- <= 6.3.1
- Safe version
6.3.2- Published
- Oct 03, 2026
This CVE was published Oct 03, 2026 and is one of 42 known issues for this plugin.
Update, patch or deactivate.
Update Kirki to 6.3.2 or a later supported release. An application-level fix should validate numeric bounds and enforce explicit authorization before executing the affected operation. The export does not disclose that operation or parameter, so this is a class-level remediation recommendation, not a verified source patch.
A safe version is available, so updating to that version or later is the preferred remediation. If an immediate update is not practical, consider a targeted application patch or temporarily restricting the affected functionality.
Deactivate only when warranted by your risk profile, or when advised by your hosting provider in the limited circumstances where the vulnerability cannot otherwise be mitigated. If you’re unsure which action is appropriate, contact Fused or your hosting provider for guidance.
Technical description
Improper Validation of Specified Quantity in Input vulnerability in Themeum Kirki kirki allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects Kirki: from n/a through 6.3.1.
CVE / CNA vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N