Kirki post_meta shortcode permits Contributor stored XSS
Kirki through 6.2.0 does not adequately sanitize input or escape output used by its post_meta shortcode. A Contributor or higher role can store a crafted shortcode in a page, and the injected script executes whenever a user views that page. Version 6.2.1 addresses the XSS among its security fixes.
- Component
- Kirki – Freeform Page Builder, Website Builder & Customizer
- Plugin slug
kirki- Affected
- <= 6.2.0
- Safe version
6.2.1- Published
- Aug 11, 2026
This CVE was published Aug 11, 2026 and is one of 42 known issues for this plugin.
Update, patch or deactivate.
Update to 6.2.1 or later. Review Contributor-authored content for untrusted post_meta shortcodes, remove injected scripts, and investigate affected visitors or privileged users if malicious content was rendered.
A safe version is available, so updating to that version or later is the preferred remediation. If an immediate update is not practical, consider a targeted application patch or temporarily restricting the affected functionality.
Deactivate only when warranted by your risk profile, or when advised by your hosting provider in the limited circumstances where the vulnerability cannot otherwise be mitigated. If you’re unsure which action is appropriate, contact Fused or your hosting provider for guidance.
Technical description
The Kirki – Freeform Page Builder, Website Builder & Customizer plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the post_meta Shortcode in all versions up to, and including, 6.2.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
CVE / CNA vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N