WordPress security changelog
MEDIUM CVE-2026-18347 Deferred

Kirki frontend collection endpoint exposes arbitrary user metadata

Kirki through 6.1.1 lets an authenticated user with the affected custom-level access supply any WordPress user ID and a user-type context to its frontend collection endpoint. Missing object authorization returns the target's email, roles, registration date, and arbitrary user_meta values, including administrator records. The public.

CVE / CNA score 4.3 CVSS 3.1 · security@wordfence.com
NVD score Pending NVD has not published its own CVSS assessment.
Component
Kirki – Freeform Page Builder, Website Builder & Customizer
Plugin slug
kirki
Affected
<= 6.1.1
Safe version
6.3.2 (confirmed by; first fixed release not established)
Published
Aug 16, 2026
Weakness
CWE-862 — Missing Authorization

This CVE was published Aug 16, 2026 and is one of 42 known issues for this plugin.

Update, patch or deactivate.

The official author release notes confirm remediation by 6.3.2; this does not establish that every intervening release was affected. The first fixed release is not established. Update the affected edition to 6.3.2 or a later maintained release on its supported branch. restrict delegated Kirki access or disable the frontend collection API and assess administrator metadata exposure. Official author release notes: https://wordpress.org/plugins/kirki/.

A safe version is available, so updating to that version or later is the preferred remediation. If an immediate update is not practical, consider a targeted application patch or temporarily restricting the affected functionality.

Deactivate only when warranted by your risk profile, or when advised by your hosting provider in the limited circumstances where the vulnerability cannot otherwise be mitigated. If you’re unsure which action is appropriate, contact Fused or your hosting provider for guidance.

Technical description

The Kirki – Freeform Page Builder, Website Builder & Customizer plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 6.1.1. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for authenticated attackers, with custom-level access and above, to read arbitrary user metadata and sensitive user record fields — including email address, assigned roles, registration date, and any user_meta values — belonging to any WordPress user including administrators, by supplying a target user ID with a user-type context to the frontend collection endpoint.

CVE / CNA vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Primary and upstream sources