Kirki: A security weakness
Kirki is affected by a security weakness. Exploitation requires an authenticated editor account. The resulting impact depends on how the affected component exposes the vulnerable operation. The published affected range is 6.0.0 to < 6.3.0.
- Component
- Kirki
- Plugin slug
kirki- Affected
- 6.0.0 to < 6.3.0
- Safe version
6.3.0- Published
- Sep 05, 2026
This CVE was published Sep 05, 2026 and is one of 42 known issues for this plugin.
Update, patch or deactivate.
Update Kirki to 6.3.0 or later, or disable and remove it until a fixed version is available.
A safe version is available, so updating to that version or later is the preferred remediation. If an immediate update is not practical, consider a targeted application patch or temporarily restricting the affected functionality.
Deactivate only when warranted by your risk profile, or when advised by your hosting provider in the limited circumstances where the vulnerability cannot otherwise be mitigated. If you’re unsure which action is appropriate, contact Fused or your hosting provider for guidance.
Technical description
The Kirki WordPress plugin before 6.3.0 does not escape a user-supplied identifier before using it in a SQL query, allowing users with editor-level access and above to append arbitrary SQL and read the contents of the database, including user credentials.
CVE / CNA vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:N/A:N