Kirki: A security weakness
Kirki is affected by a security weakness. Exposure depends on how the affected operation is made reachable by the site. The resulting impact depends on how the affected component exposes the vulnerable operation. The published affected range is 6.0.0 to < 6.3.0.
- Component
- Kirki
- Plugin slug
kirki- Affected
- 6.0.0 to < 6.3.0
- Safe version
6.3.0- Published
- Sep 05, 2026
This CVE was published Sep 05, 2026 and is one of 42 known issues for this plugin.
Update, patch or deactivate.
Update Kirki to 6.3.0 or later, or disable and remove it until a fixed version is available.
A safe version is available, so updating to that version or later is the preferred remediation. If an immediate update is not practical, consider a targeted application patch or temporarily restricting the affected functionality.
Deactivate only when warranted by your risk profile, or when advised by your hosting provider in the limited circumstances where the vulnerability cannot otherwise be mitigated. If you’re unsure which action is appropriate, contact Fused or your hosting provider for guidance.
Technical description
The Kirki WordPress plugin before 6.3.0 does not check that a user is allowed to act on a collaboration comment before changing its state, allowing users whom an administrator has granted content-level access to the page builder to modify comments left by other users, including on pages they cannot themselves open.
CVE / CNA vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:L/A:N