WordPress security changelog
MEDIUM CVE-2026-9281 Deferred

Master Addons For Elementor – Widgets, Extensions, Theme Builder, Popup Builder & Template Kits: Cross-site scripting

Master Addons For Elementor – Widgets, Extensions, Theme Builder, Popup Builder & Template Kits is affected by cross-site scripting. Exploitation requires an authenticated author account. Injected script can execute in the affected site's origin when the vulnerable output is viewed. The published affected range is <= 3.1.0.

CVE / CNA score 6.4 CVSS 3.1 · security@wordfence.com
NVD score Pending NVD has not published its own CVSS assessment.
Component
Master Addons For Elementor – Widgets, Extensions, Theme Builder, Popup Builder & Template Kits
Plugin slug
master-addons
Affected
<= 3.1.0
Safe version
3.1.1
Published
Jun 06, 2026
Weakness
CWE-79 — Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

This CVE was published Jun 06, 2026 and is one of 29 known issues for this plugin.

Update, patch or deactivate.

The official author release notes confirm remediation by 3.1.1; this does not establish that every intervening release was affected. Update the affected edition to 3.1.1 or a later maintained release on its supported branch. Master Addons 3.1.1 removes the Custom JS extension from the free edition and adds save/render capability checks in Pro. Official author release notes: https://wordpress.org/plugins/master-addons/#developers.

A safe version is available, so updating to that version or later is the preferred remediation. If an immediate update is not practical, consider a targeted application patch or temporarily restricting the affected functionality.

Deactivate only when warranted by your risk profile, or when advised by your hosting provider in the limited circumstances where the vulnerability cannot otherwise be mitigated. If you’re unsure which action is appropriate, contact Fused or your hosting provider for guidance.

Technical description

The Master Addons For Elementor – Widgets, Extensions, Theme Builder, Popup Builder & Template Kits plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'jtlma_custom_js' Page Setting (Custom JS Extension) in all versions up to, and including, 3.1.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The unfiltered_html capability check is only enforced during Elementor control registration (UI rendering) and not during the save process, enabling Author-level users to inject the jtlma_custom_js setting directly via a crafted POST request to admin-ajax.php?action=elementor_ajax, bypassing the UI-level restriction entirely.

CVE / CNA vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

Primary and upstream sources