Media LIbrary Assistant: Cross-site request forgery
Media LIbrary Assistant <= 3.42 permits cross-site request forgery: an attacker without an account can cause a victim’s browser to send a request that is accepted without adequate request-origin verification. Victim interaction is required by the supplied CVSS vector. The CVSS vector assigns limited integrity impact, but the export does not identify which plugin action or setting is changed. The target endpoint, parameters and required victim role are not disclosed.
- Component
- Media LIbrary Assistant
- Plugin slug
media-library-assistant- Affected
- <= 3.42
- Safe version
3.43- Published
- Oct 26, 2026
This CVE was published Oct 26, 2026 and is one of 50 known issues for this plugin.
Update, patch or deactivate.
Update Media LIbrary Assistant to 3.43 or later. Require a valid action-specific anti-CSRF nonce and the appropriate server-side capability check for every state-changing request. Reject missing or invalid tokens before acting; authentication alone does not establish that the user intended the request.
A safe version is available, so updating to that version or later is the preferred remediation. If an immediate update is not practical, consider a targeted application patch or temporarily restricting the affected functionality.
Deactivate only when warranted by your risk profile, or when advised by your hosting provider in the limited circumstances where the vulnerability cannot otherwise be mitigated. If you’re unsure which action is appropriate, contact Fused or your hosting provider for guidance.
Technical description
Cross-Site Request Forgery (CSRF) vulnerability in David Lingren Media LIbrary Assistant media-library-assistant allows Cross Site Request Forgery.This issue affects Media LIbrary Assistant: from n/a through 3.42.
CVE / CNA vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N