Newsletters Lite post target attributes permit contributor stored XSS
Newsletters Lite through 4.15 lets an authenticated Contributor place an attribute-breakout payload in the target attribute of a newsletters_post shortcode. posts_single() propagates that shortcode attribute into the global wpml_target value, and the post_thumbnail branch of shortcode_posts() concatenates it directly into an anchor target HTML attribute without esc_attr(). Rendering the stored shortcode can therefore execute attacker-controlled script in visitors' browsers. This content-rendering path does not use a separate plugin endpoint, action or request parameter.
- Component
- Newsletters
- Plugin slug
newsletters-lite- Affected
- <= 4.15
- Safe version
4.16- Published
- Jul 29, 2026
This CVE was published Jul 29, 2026 and is one of 37 known issues for this plugin.
Update, patch or deactivate.
Update Newsletters Lite to 4.16 or later. Review Contributor-authored newsletters_post shortcodes for unexpected target values.
A safe version is available, so updating to that version or later is the preferred remediation. If an immediate update is not practical, consider a targeted application patch or temporarily restricting the affected functionality.
Deactivate only when warranted by your risk profile, or when advised by your hosting provider in the limited circumstances where the vulnerability cannot otherwise be mitigated. If you’re unsure which action is appropriate, contact Fused or your hosting provider for guidance.
Technical description
The Newsletters Lite plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'target' attribute of the [newsletters_post] shortcode in versions up to and including 4.15. This is due to insufficient input sanitization and output escaping in the posts_single() function which propagates the attacker-controlled 'target' attribute into the global $wpml_target, and in the shortcode_posts() 'post_thumbnail' handler which concatenates $wpml_target into a target="..." HTML attribute without esc_attr(). This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
CVE / CNA vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Primary and upstream sources
- NVD record for CVE-2026-12938
- WordPress upstream reference plugins.trac.wordpress.org
- WordPress upstream reference plugins.trac.wordpress.org
- WordPress upstream reference plugins.trac.wordpress.org
- WordPress upstream reference plugins.trac.wordpress.org
- WordPress upstream reference plugins.trac.wordpress.org
- WordPress upstream reference plugins.trac.wordpress.org
- Wordfence advisory wordfence.com