Newsletters Lite thumbnail link attributes permit contributor stored XSS
Newsletters Lite through 4.15 lets an authenticated Contributor supply a malicious link attribute to the post_thumbnail or newsletters_post_thumbnail shortcode. The shortcode dispatcher passes the attributes to post_thumbnail(), which concatenates the attacker-controlled link directly into an anchor href without esc_url() or esc_attr(). Rendering the stored shortcode therefore turns the value into executable page markup and can run script in visitors' browsers. This content-rendering path does not use a separate plugin endpoint, action or request parameter.
- Component
- Newsletters
- Plugin slug
newsletters-lite- Affected
- <= 4.15
- Safe version
4.16- Published
- Jul 29, 2026
This CVE was published Jul 29, 2026 and is one of 37 known issues for this plugin.
Update, patch or deactivate.
Update Newsletters Lite to 4.16 or later. Review Contributor-authored newsletter and post content for unexpected post_thumbnail or newsletters_post_thumbnail link values.
A safe version is available, so updating to that version or later is the preferred remediation. If an immediate update is not practical, consider a targeted application patch or temporarily restricting the affected functionality.
Deactivate only when warranted by your risk profile, or when advised by your hosting provider in the limited circumstances where the vulnerability cannot otherwise be mitigated. If you’re unsure which action is appropriate, contact Fused or your hosting provider for guidance.
Technical description
The Newsletters Lite plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'link' attribute of the post_thumbnail (and newsletters_post_thumbnail) shortcodes in versions up to and including 4.15. This is due to insufficient input sanitization and output escaping in the post_thumbnail() method in helpers/shortcode.php, which concatenates the user-controlled $link shortcode attribute directly into an href attribute without esc_url() or esc_attr(). This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
CVE / CNA vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Primary and upstream sources
- NVD record for CVE-2026-12939
- WordPress upstream reference plugins.trac.wordpress.org
- WordPress upstream reference plugins.trac.wordpress.org
- WordPress upstream reference plugins.trac.wordpress.org
- WordPress upstream reference plugins.trac.wordpress.org
- WordPress upstream reference plugins.trac.wordpress.org
- Wordfence advisory wordfence.com