Qi Addons For Elementor
Qi Addons For Elementor adds Elementor widgets and design elements for creating customized WordPress page layouts and content sections.
Qi Addons For Elementor (qi-addons-for-elementor) is a WordPress plugin with 13 published CVE records in this archive. The latest tracked vulnerability was published Oct 25, 2026; the highest published CVSS base score is 7.5.
qi-addons-for-elementorCVE-2026-115183: Qi Addons for Elementor: Contributor HTML-form injection in heading text
Qi Addons for Elementor decodes HTML entities in widget heading text without adequately sanitizing the decoded result. A Contributor or higher can supply heading text that becomes live HTML forms in posts, including password inputs that submit to an external host, bypassing markup restrictions WordPress would otherwise apply. This supports credential-harvesting content; arbitrary JavaScript execution is not established by this description. The exact widget identifier, heading parameter and processing function are not disclosed in the export. Published affected versions: < 1.11.2.
| Safe version |
|
||
|---|---|---|---|
| Oct 25, 2026 |
CVE-2026-115183
Qi Addons for Elementor: Contributor HTML-form injection in heading text
Qi Addons for Elementor decodes HTML entities in widget heading text without adequately sanitizing the decoded result. A Contributor or higher can supply heading text that becomes live HTML forms in posts, including password inputs that submit to an external host, bypassing markup restrictions WordPress would otherwise apply. This supports credential-harvesting content; arbitrary JavaScript execution is not established by this description. The exact widget identifier, heading parameter and processing function are not disclosed in the export. Published affected versions: < 1.11.2.
|
1.11.2 |
CVEPending
|
| Sep 30, 2026 |
CVE-2026-62079
Qi Addons For Elementor: Cross-site scripting
Contributor Cross Site Scripting (XSS) in Qi Addons For Elementor <= 1.11 versions. The reported impact is browser script execution in the affected site's origin. The injected field, rendering context and exact victim interaction are unspecified. The authoritative export does not identify the vulnerable endpoint, action, parameter or function, so the precise input-to-operation path cannot be established from this snapshot. The authoritative export identifies the fixed release as 1.11.1.
|
1.11.1 |
CVE6.5
|
| Sep 18, 2026 |
CVE-2026-92249
Qi Addons For Elementor: Reflected XSS in search-result table of contents
The Qi Addons For Elementor plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 's' parameter in all versions up to, and including, 1.11 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires the Table of Contents widget to be placed on a template that renders on the WordPress search-results page (e.g., a sitewide header or footer template) with the 'Limit ToC to Main Page Content' option left at its default value of No, so the widget scans the search-results heading that reflects the unsanitized `s` parameter. Exposure depends on the widget scanning search-result headings outside the main content area; the complete request-to-widget route is not disclosed. Affected versions reported by the CNA: <= 1.11. Official changelog review confirms 1.11.1 as a fixed release for this issue.
|
1.11.1 |
CVE6.1
|
| Aug 02, 2025 |
CVE-2025-8146
Qi Addons For Elementor: Cross-site scripting
Qi Addons For Elementor is affected by cross-site scripting. Exploitation requires an authenticated contributor account. Injected script can execute in the affected site's origin when the vulnerable output is viewed.
|
See mitigation notes |
CVE6.4
|
| Jun 28, 2025 |
CVE-2025-6252
Qi Addons For Elementor: Cross-site scripting
Qi Addons For Elementor is affected by cross-site scripting. Exploitation requires an authenticated contributor account. Injected script can execute in the affected site's origin when the vulnerable output is viewed.
|
See mitigation notes |
CVE6.4
|
| Feb 04, 2025 |
CVE-2024-13699
Qi Addons For Elementor: Cross-site scripting
Qi Addons For Elementor is affected by cross-site scripting. Exploitation requires an authenticated contributor account. Injected script can execute in the affected site's origin when the vulnerable output is viewed.
|
See mitigation notes |
CVE6.4
|
| Oct 23, 2024 |
CVE-2024-9530
Qi Addons For Elementor: Sensitive information exposure
Qi Addons For Elementor is affected by sensitive information exposure. Exploitation requires an authenticated contributor account. Successful exploitation can disclose data that should not be available to the caller.
|
See mitigation notes |
CVE4.3
|
| Jun 07, 2024 |
CVE-2024-4887
Qi Addons For Elementor: Filesystem traversal
Qi Addons For Elementor is affected by filesystem traversal. Exploitation requires an authenticated contributor account. A crafted path can escape the intended directory and reach files or directories elsewhere on the server.
|
See mitigation notes |
CVE7.5
|
| Jun 06, 2024 |
CVE-2024-4364
Qi Addons For Elementor: Cross-site scripting
Qi Addons For Elementor is affected by cross-site scripting. Exploitation requires an authenticated contributor account. Injected script can execute in the affected site's origin when the vulnerable output is viewed.
|
See mitigation notes |
CVE6.4
|
| May 17, 2024 |
CVE-2023-47679
Qi Addons For Elementor: Filesystem traversal
Qi Addons For Elementor is affected by filesystem traversal. Exposure depends on how the affected operation is made reachable by the site. A crafted path can escape the intended directory and reach files or directories elsewhere on the server.
|
See mitigation notes |
CVE6.4
|
| Apr 27, 2024 |
CVE-2024-3309
Qi Addons For Elementor: Cross-site scripting
Qi Addons For Elementor is affected by cross-site scripting. Exploitation requires an authenticated contributor account. Injected script can execute in the affected site's origin when the vulnerable output is viewed.
|
See mitigation notes |
CVE6.4
|
| Apr 09, 2024 |
CVE-2024-0826
Qi Addons For Elementor: Cross-site scripting
Qi Addons For Elementor is affected by cross-site scripting. Exploitation requires an authenticated contributor account. Injected script can execute in the affected site's origin when the vulnerable output is viewed.
|
See mitigation notes |
CVE6.4
|
| Nov 14, 2023 |
CVE-2023-47680
Qi Addons For Elementor: Cross-site scripting
Qi Addons For Elementor is affected by cross-site scripting. Exposure depends on how the affected operation is made reachable by the site. Injected script can execute in the affected site's origin when the vulnerable output is viewed.
|
See mitigation notes |
CVE6.5
|