Relevanssi: PHP object injection
Relevanssi: The CVSS vector requires an authenticated attacker with high privileges; the minimum WordPress role is not disclosed. Attacker-controlled serialized data can reach unsafe deserialization and instantiate PHP objects. The source rates confidentiality, integrity and availability impacts as high. A usable gadget chain and a particular code-execution path are not established in the export. The authoritative export does not name the vulnerable endpoint, request action, parameter or implementation function. Published affected versions: <= 4.28.4.
- Component
- Relevanssi
- Plugin slug
relevanssi- Affected
- <= 4.28.4
- Safe version
4.28.5- Published
- Oct 24, 2026
This CVE was published Oct 24, 2026 and is one of 17 known issues for this plugin.
Update, patch or deactivate.
Update Relevanssi to 4.28.5 or later. Remove unsafe deserialization of untrusted data or use a strictly validated non-object data format; restrict access to the affected operation until updated.
A safe version is available, so updating to that version or later is the preferred remediation. If an immediate update is not practical, consider a targeted application patch or temporarily restricting the affected functionality.
Deactivate only when warranted by your risk profile, or when advised by your hosting provider in the limited circumstances where the vulnerability cannot otherwise be mitigated. If you’re unsure which action is appropriate, contact Fused or your hosting provider for guidance.
Technical description
Deserialization of Untrusted Data vulnerability in Christoph Vielgrader Relevanssi relevanssi allows Object Injection.This issue affects Relevanssi : from n/a through 4.28.4.
CVE / CNA vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H