ThemeREX Addons: Server-side request forgery
Server-Side Request Forgery (SSRF) vulnerability in ThemeREX Group ThemeREX Addons trx_addons allows Server Side Request Forgery.This issue affects ThemeREX Addons: from n/a through 2.46.0. The supplied CVSS vector requires low privileges, but no minimum WordPress role is identified. Attacker-controlled request data causes an unintended server-side request. The destination parameter, protocols and reachable network locations are not disclosed. The authoritative export does not identify the vulnerable endpoint, action, parameter or function, so the precise input-to-operation path cannot be established from this snapshot. The authoritative export identifies the fixed release as 2.47.0.
- Component
- ThemeREX Addons
- Plugin slug
trx-addons- Affected
- <= 2.46.0
- Safe version
2.47.0- Published
- Oct 02, 2026
This CVE was published Oct 02, 2026 and is one of 7 known issues for this plugin.
Update, patch or deactivate.
Update ThemeREX Addons to 2.47.0 or a later supported release. Allowlist destinations and protocols, validate resolved addresses and redirects, and reject disallowed internal targets.
A safe version is available, so updating to that version or later is the preferred remediation. If an immediate update is not practical, consider a targeted application patch or temporarily restricting the affected functionality.
Deactivate only when warranted by your risk profile, or when advised by your hosting provider in the limited circumstances where the vulnerability cannot otherwise be mitigated. If you’re unsure which action is appropriate, contact Fused or your hosting provider for guidance.
Technical description
Server-Side Request Forgery (SSRF) vulnerability in ThemeREX Group ThemeREX Addons trx_addons allows Server Side Request Forgery.This issue affects ThemeREX Addons: from n/a through 2.46.0.
CVE / CNA vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N