WordPress security changelog
HIGH CVE-2026-14558 Deferred

User Frontend permits Editor-level PHP object injection

User Frontend before 4.3.10 does not properly validate field-type definitions and deserializes user-controlled post metadata while rendering submitted posts. An Editor can inject PHP objects; where the site has a compatible POP chain, this can lead to remote code execution.

CVE / CNA score 7.2 CVSS 3.1 · 134c704f-9b21-4f2e-91b3-4a467353bcc0
NVD score Pending NVD has not published its own CVSS assessment.
Component
User Frontend
Plugin slug
user-frontend
Affected
< 4.3.10
Safe version
4.3.10
Published
Aug 28, 2026
Weakness
CWE-502 — Deserialization of Untrusted Data

This CVE was published Aug 28, 2026 and is one of 4 known issues for this plugin.

Update, patch or deactivate.

Update User Frontend to 4.3.10 or later, restrict Editor access until updated and investigate unexpected serialized post metadata or code execution.

A safe version is available, so updating to that version or later is the preferred remediation. If an immediate update is not practical, consider a targeted application patch or temporarily restricting the affected functionality.

Deactivate only when warranted by your risk profile, or when advised by your hosting provider in the limited circumstances where the vulnerability cannot otherwise be mitigated. If you’re unsure which action is appropriate, contact Fused or your hosting provider for guidance.

Technical description

The User Frontend WordPress plugin before 4.3.10 does not properly validate field type definitions and deserialises user-controlled post metadata when rendering submitted posts, allowing users with Editor-level access and above to inject arbitrary PHP objects, which can lead to remote code execution when a suitable POP chain is present on the site.

CVE / CNA vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Primary and upstream sources