User Profile Builder contributors can store script through an optional shortcode
User Profile Builder before 4.0.1 fails to escape output from an optional shortcode. When that shortcode is enabled, a Contributor can store script that executes for anyone viewing the affected content, including Administrators; the shortcode is disabled by default.
- Component
- User Profile Builder
- Plugin slug
user-profile-builder- Affected
- 3.3.4 to < 4.0.1
- Safe version
4.0.1- Published
- Aug 29, 2026
This CVE was published Aug 29, 2026 and is one of 8 known issues for this plugin.
Update, patch or deactivate.
Update to 4.0.1 or later, keep the optional shortcode disabled when unused, and review Contributor-authored content for script-capable values.
A safe version is available, so updating to that version or later is the preferred remediation. If an immediate update is not practical, consider a targeted application patch or temporarily restricting the affected functionality.
Deactivate only when warranted by your risk profile, or when advised by your hosting provider in the limited circumstances where the vulnerability cannot otherwise be mitigated. If you’re unsure which action is appropriate, contact Fused or your hosting provider for guidance.
Technical description
The User Profile Builder WordPress plugin before 4.0.1 does not escape the output of one of its optional shortcodes, allowing users with a role as low as contributor to perform Stored Cross-Site Scripting attacks against any user viewing the affected content, including administrators. The shortcode is not enabled by default.
CVE / CNA vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H