WordPress security changelog
MEDIUM CVE-2026-76547 Deferred

User Profile Builder configuration imports permit PHP object injection

User Profile Builder before 4.0.1 deserializes configuration-import data without validating its type. An Administrator can inject a PHP object when the optional free import add-on is enabled. The plugin does not contain a usable gadget chain itself, so further impact requires a suitable gadget in another installed component.

CVE / CNA score 6.6 CVSS 3.1 · 134c704f-9b21-4f2e-91b3-4a467353bcc0
NVD score Pending NVD has not published its own CVSS assessment.
Component
User Profile Builder
Plugin slug
user-profile-builder
Affected
3.3.4 to < 4.0.1
Safe version
4.0.1
Published
Aug 29, 2026
Weakness
CWE-502 — Deserialization of Untrusted Data

This CVE was published Aug 29, 2026 and is one of 8 known issues for this plugin.

Update, patch or deactivate.

Update to 4.0.1 or later, keep the optional import add-on disabled when unused, and accept configuration files only from trusted administrators.

A safe version is available, so updating to that version or later is the preferred remediation. If an immediate update is not practical, consider a targeted application patch or temporarily restricting the affected functionality.

Deactivate only when warranted by your risk profile, or when advised by your hosting provider in the limited circumstances where the vulnerability cannot otherwise be mitigated. If you’re unsure which action is appropriate, contact Fused or your hosting provider for guidance.

Technical description

The User Profile Builder WordPress plugin before 4.0.1 does not validate the type of data being deserialized when importing a configuration file, allowing high privilege users such as administrators to conduct PHP Object Injection. The affected feature is a free add-on which is disabled by default, and no POP chain is present in the User Profile Builder WordPress plugin before 4.0.1 itself, so further impact requires a suitable gadget from another installed User Profile Builder WordPress plugin before 4.0.1 or .

CVE / CNA vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H

Primary and upstream sources