WordPress security changelog
MEDIUM CVE-2026-19945 Deferred

WP Crowdfunding permits subscriber scripts to run in an administrator's session

WP Crowdfunding through 2.2.1 inadequately sanitizes and escapes first_name. A Subscriber or higher-privileged user can save script content that runs when the profile is rendered. An administrator viewing a user's profile through show_user_id can trigger the stored payload in the administrator's browser session.

CVE / CNA score 6.4 CVSS 3.1 · security@wordfence.com
NVD score Pending NVD has not published its own CVSS assessment.
Component
WP Crowdfunding
Plugin slug
wp-crowdfunding
Affected
<= 2.2.1
Safe version
2.2.2
Published
Sep 09, 2026
Weakness
CWE-79 — Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

This CVE was published Sep 09, 2026 and is one of 20 known issues for this plugin.

Update, patch or deactivate.

Update WP Crowdfunding to 2.2.2 or later. The official changelog identifies the matching fix. The checked current release is 2.2.2.

A safe version is available, so updating to that version or later is the preferred remediation. If an immediate update is not practical, consider a targeted application patch or temporarily restricting the affected functionality.

Deactivate only when warranted by your risk profile, or when advised by your hosting provider in the limited circumstances where the vulnerability cannot otherwise be mitigated. If you’re unsure which action is appropriate, contact Fused or your hosting provider for guidance.

Technical description

The WP Crowdfunding plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'first_name' parameter in all versions up to, and including, 2.2.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. An administrator viewing any user's profile via the ?show_user_id= parameter will render the attacker's stored payload in the admin's browser session, enabling cross-privilege script execution.

CVE / CNA vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

Primary and upstream sources